Hi,
I need to update process_control_timeout from 0 (Off) to 5 seconds.
This is helpful because the PHP FPM reloads every deployment, and running processes will be killed and returned HTTP status 502 Bad gateway immediately.
Allowing the PHP FPM processes to wait at least 5 seconds to complete all running processes before reloading will prevent the error.
I suggest Ploi either:
- Changes the default
process_control_timeoutto 5 seconds. - Allows editing PHP FPM configuration files at the server Manage tab.